Конвертирование видео кодеком Н

Конвертирование видео DivX, XviD, VP7 и т.п. кодеками.

Статья основана на статье "Конвертирование видео кодеком Н.264 Ateme", только адаптирована под другие кодеки

1. Необходимые программы.

Для начала нужно скачать следующие программы:

1. GordianKnot Rip Pack

2. HeadAC3he или Ahead Nero (Nero 6) и дополнительные плагины для Nero Wave Editor (оф. сайт или моя сборка) (описание только для HeadAC3he)

3. K-Lite Codec Pack (необязательно).

1. Запускаем программу Gordian Knot [image] и видим окно:

Выбираем Сграбить VOB’ы

Откроется программа DVD Decrypter:

Выбираем необходимый фильм(VTS_01 или VTS_02) и жмём на картинку.

После того, как VOB’ы сграбятся выбираем Подготовить VOB’ы (Gordian Knot).

Откроется программа DGIndex. Жмём F2 и выбираем наши VOB’ы:

Жмём ОК.

Нажмите F5 для предварительного просмотра, для выхода из него нажмите "ESC".Если "Framerate" - 29.970 (NTSC) и "Video Type" - FILM при процентном отношении выше или равно 95%, выберите "ForceFilm" в "Field Operation", в другом случае убедитесь, что он отключен.

В "Dolby Digital" выберите "Demux All Tracks".

После этого жмём F4 и сохраняем проект (при этом также автоматически сохранится звуковая дорожка в формате AC3).

Теперь нужно конвертировать дорожку в более удобный формат. Если вы будете сохранять конечный фильм в *.avi, то советую выбирать только mp3 с постоянным битрейтом (если будете выбирать VBR качество(переменный битрейт) или другой кодек, основанный на переменном битрейте, то рассинхронизация звука и видео вам практически обеспечена). Я предпочитаю вместо "авишки" использовать "матрёшку"(matroska) - *.mkv, т.к. этот контейнер отлично понимает переменных битрейт и звук можно будет кодировать более совершенным кодеком (например ogg).

Но есть один маленький минус - в DivX совместимых плеерах этот формат не будет проигрываться (они его пока не понимают, но т.к. я все фильмы смотрю на компе, то для меня этот минус несущественен).Т.е тогда ваш выбор - DivX+mp3=avi

Итак, запускаем HeadAC3he и открываем наш AC3 файл и сохраняем в формате ogg.

Настроить можете так, как изображено на скрине:

1. Размер будущего файла

2. Формат будущего файла

3. Настройки кодирования звука (ориентируйтесь на размер файла, хотя у меня почти всегда стоят такие настройки).

Мы получили звук нашего фильма(audio.ogg) и файл проэкта(*.d2v).

Опять открывает Gordian Knot и жмём кнопку открыть *.d2v (кнопка в левом углу программы) и открываем наш проект.

Теперь у нас появилось окно с фильмом:

Теперь здесь выберете Смотреть ->С изм. Размеров.

Вы видите на скриншоте чёрные полосы снизу и сверху фильма; нам их нужно убрать.

Не закрывая этого окна, переходим на закладку Разрешение. И в секции Урезать (перед изменением размеров!) жмём кнопку Авто.

После этого отметьте Умное урезание (полное). Так же можете изменить разрешение фильма, но я почти всегда не изменяю его:

Но если битрейд низкий, то индикатор Бит/Пиксель*Кад будет жёлтым и следует немного уменьшить разрешение (кстати, поэтому я и вычисляю битрейд сначала вручную):

Теперь займёмся просчётом битрейда:

1.Сюда вписываем размер сжатого нами аудио файла (audio.ogg).

2. Выставляем подсчёт битрейда для того кодека , которым Вы будите кодировать. Если вы будите кодировать в VP7, то выбирайте DivX 5, VP6 - Divx 3.

3.Если вы кодируете на 1CD, то оставляем 700Mb.

4.Получаем средний битрейд.

Теперь жмём кнопку Сохранить & Кодировать на окне с фильмом и в следующем окне ещё раз Сохр. И сохраняем файл с расширением *.avs.

Теперь Gordian Knot можно закрыть.

Работа с VirtualDubMod.

Запускаем VirtualDubMod, жмём Ctrl+O, и открываем наш *.avs файл.

Теперь внимательно присмотритесь к видео, нет ли искажений при движении таких вот горизонтальных полос:

Если есть, то придётся использовать фильтры. Чмём Ctrl+F, Add и выбираем фильтр deinterlace, вместо стандартного фильтра можно также использовать фильтр сторонних разработчиков. "Заряженную" всеми необходимыми фильтрами русскую версию VirtualDubMod 1.5.10.1 можно скачать здесь.

Теперь необходимо добавить звуковую дорожку: Streams-> Stream list, Add и открываем наш файл со звуком (audio.ogg), Ok.

Жмём F7.

Тип файла - *.mkv

Video mode - если использовали фильтры, то Full processing mode, если ничего не использовали, то - Fast recompress.

Compression - жмём Change и выбираем кодек. Настраиваем его и жмём Ok (я рекомендую двухпроходное сжатие - дольше, но качественней).

Пример использования двухпроходного сжатия на примере кодека VP7 можете прочитать здесь.

У вас должно быть примерно следующее:

Теперь жмём Сохранить и ждём...

P.S. Я смотрю такие фильмы (да и другие тоже) проигрывателем Media Player Classic, который входит в пакет K-Lite Codec Pack

На этом всё! Спасибо за прочтение материала.

Copyright ©2005, Алексеев Алексей aka Cudesnik